What happens when a SDK deprecates support for older versions of operating systems?

82 views
0

Suppose that Google Mobile Ads SDK lists a minimum Android version of API level 16 (Jelly Bean / 4.1). Suppose that my app, which leverages this SDK, also supports this minimum Android version.

What happens to a user running this minimum version when there is a new Android release and support for API level 16 is deprecated by the SDK? Will the user no longer be able to use the app, or is it simply that the functionality associated with the SDK will be unusable.

I am slowly learning mobile dev so please be kind 🙂

In: 0

If the user already had the app they’ll be stuck on the last version that supports them and won’t be able to update. New users wouldn’t be able to download the app.